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This manual describes the functions and operating procedures of GateDX-P. To ensure
correct use, please read this manual thoroughly before beginning operation. After
reading the manual, keep it in a convenient location for quick reference in the event a
question arises.

Gate-DXP is a software program that acquires data from the DX100P/DX200 and
transfers it to DAQLOGGER or Remote Monitor.

The contents of this manual are subject to change without prior notice as a result of
continuing improvements to the software’s performance and functions.

Every effort has been made in the preparation of this manual to ensure the accuracy
of its contents. However, should you have any questions or find any errors, please
contact your nearest YOKOGAWA representative as listed on the back cover of this
manual.

Copying or reproducing all or any part of the contents of this manual without the
permission of Yokogawa Electric Corporation is strictly prohibited.

Use of this product (software and this manual) on more than one computer at the
same time is prohibited. Use by more than one user is also prohibited.

Transfer or lending of this product to any third party is prohibited.

Yokogawa Electric Corporation provides no guarantees other than for physical
deficiencies found on the original disk or this manual upon opening the product
package.

License numbers will not be reissued. Please keep the license number in a safe
place.

Copyrights for the programs included on the CD-ROM are attributable to Yokogawa
Electric Corporation.

DAQWORX, DAQLOGGER, and DAQEXPLORER are registered trademarks or
trademarks of Yokogawa Electric Corporation.

Microsoft and Windows are registered trademarks or trademarks of Microsoft
Corporation in the United States and/or other countries.

Adobe and Acrobat are registered trademarks or trademarks of Adobe Systems
Incorporated.

Company and product names that appear in this manual are registered trademarks or
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registered trademark or trademark symbols (® and ™).
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Terms and Conditions of the Software License

NOTICE - PLEASE READ CAREFULLY BEFORE USE

Thank you very much for purchasing this medium containing a software program and related documentation provided by Yokogawa Electric Corporation (hereinafter called
“Yokogawa”), and the program contained, embedded, inserted or used in the medium (hereinafter called the “Yokogawa Software Program”).

By installing the Yokogawa Software Program, you acknowledge that you understand and fully agree to the “Terms and Conditions of the Software License” (hereinafter called
“Terms and Conditions”) which is written in the documentation and separately attached. Accordingly, the Terms and Conditions bind you.

The Yokogawa Software Program and its related documentation including ownership of copyright shall remain the exclusive property of Yokogawa or those third parties who
grants Yokogawa the rights.

Yokogawa hereby grants you permission to use the Yokogawa Software Program on the conditions that you agree to the Terms and Conditions before you install it in or onto
a computer.

IF YOU DO NOT AGREE TO THE TERMS AND CONDITIONS, YOU CANNOT INSTALL THIS MEDIUM, AND MUST PROMPTLY RETURN IT TO YOKOGAWA OR ITS
DESIGNATED PARTY.

Terms and Conditions of the Software License

Yokogawa Electric Corporation, a Japanese corporation (hereinafter called “Yokogawa”), grants permission to use this Yokogawa Software Program (hereinafter called the
“Licensed Software”) to you on the conditions that you agrees to the terms and conditions stipulated in Article 1 hereof.

You, as the Licensee (hereinafter called “Licensee”), shall agree to the following terms and conditions on the software license (hereinafter called the “Agreement”) when the
Licensed Software is installed by the Licensee.

Please note that Yokogawa grants the Licensee permission to use the Licensed Software under the terms and conditions herein and in no event shall Yokogawa intend to
sell or transfer the Licensed Software to the Licensee.

Article 1 (Licensed Software under these Terms and Conditions)
1.1The terms and conditions stipulated herein shall bind any Licensee who purchases the Licensed Software on the condition that the Licensee consents to agree to the
terms and conditions stipulated herein.
1.2The “Licensed Software” and required number of license herein shall be specified in the following paragraphs (1) and (2) respectively. The Licensed Software means and
includes all applicable programs and documentation, without limitation, all proprietary technology, algorithms, a factor, invariant, process and/or other know-how contained
therein. These terms and conditions shall also govern any additional software to the Licensed Software inclusive of its version-up or revision-up if Yokogawa provides them
to the Licensee.
(1) Licensed Software Name: Data Acquisition Software Suite DAQWORX
(2) Number of License: Same number as those media for the Licensed Software shall be acquired for installation.

Article 2 (Grant of License)

2.1Yokogawa grants the Licensee, for the purpose of single use, non-exclusive and non-transferable license of the Licensed Software with the license fee separately agreed
upon by both parties.

2.2The Licensee is, unless otherwise agreed upon in writing by Yokogawa, not entitled to change, sell, distribute, transfer, or sublicense the Licensed Software.

2.3The Licensed Software shall not be copied in part or in whole except for keeping one (1) copy for back-up purpose. The Licensee shall secure or supervise the copy of
the Licensed Software by the Licensee itself with great, strict, and due care.

2.4The Licensed Software remains the exclusive property of Yokogawa and, if any, those of third parties from whom Yokogawa is sublicensed (hereinafter such third party’s
software is called “Third Party Software”, which may include any software program made or coded by affiliates of Yokogawa). In no event shall the Licensee dump, reverse
assemble, reverse compile, or reverse engineer the Licensed Software so that the Licensee may translate the Licensed Software into other programs or change it into a
man-readable form from the source code of the Licensed Software. Unless otherwise separately agreed upon by Yokogawa, Yokogawa shall not provide the Licensee the
source code for the Licensed Software.

2.5The Licensed Software and its related documentation inclusive of its ownership of copyright shall be the proprietary property of Yokogawa or a third party who grants
Yokogawa the rights. In no event shall the Licensee transfer, lease, sublicense, or assign any rights relating to the Licensed Software.

2.6Yokogawa may use or add copy protection in or onto the Licensed Software. In no event shall, regardless of the purpose, the Licensee remove or attempt to remove such
copy protection.

2.7The Licensed Software may include the Third Party Software. In the case that Yokogawa is granted permission to sublicense to third parties by any licensors (sub-licensor)
of the Third Party Software under different terms and conditions than those stipulated in this Agreement, the Licensee shall observe such terms and conditions of which
Yokogawa notifies the Licensee in writing separately.

2.8In no event shall the Licensee modify, remove or delete a copyright notice of Yokogawa and its licenser contained in the Licensed Software, including any copy thereof.

Article 3 (Restriction of Specific Use)
3.1The Licensed Software shall not be intended specifically to be designed, developed, constructed, manufactured, distributed or maintained for the purpose of the following
events:
a) Operation of any aviation, vessel, or support of those operations from the ground;
b) Operation of nuclear products, its facilities and/or radiation apparatus;,
c) Operation of nuclear weapons, chemical weapons and/or biological weapons, or railroad; or
d) Operation of medical instrumentation directly utilized for humankind or the human body.
3.2Even if the Licensee uses the Licensed Software for the purposes in the preceding Paragraph 3.1, Yokogawa has no liability to or responsibility for any claims or damages
arising out of the use or operations of the Licensed Software, and the Licensee agrees, on its own responsibility, to solve and settle the claims and damages and to defend,
indemnify or hold Yokogawa totally harmless, from or against any liabilities, losses, damages and expenses (including fees for recalling the Products and reasonable
attorney’s fees and court costs), or claims arising out of and related to the above-said claims and damages.

Article 4 (Warranty)

4.1The Licensee shall agree that the Licensed Software shall be provided to the Licensee on an “as is” basis when delivered. If defect(s), such as damage to the medium of
the Licensed Software, attributable to Yokogawa is found, Yokogawa agrees to replace, free of charge, any Licensed Software on condition that the defective Licensed
Software shall be returned to Yokogawa'’s specified authorized service facility within 12 month from the delivery of Yokogawa after opening the Package at the Licensee’s
expense. As the Licensed Software is provided to the Licensee on an “as is” basis when delivered, in no event shall Yokogawa warrant that any information on or in the
Licensed Software, including without limitation, data on computer programs and program listings, be completely accurate, correct, reliable, or the most updated.

4.2Notwithstanding the preceding Paragraph 4.1, when Third Party Software is included in the Licensed Software, the warranty period and related conditions that apply shall
be those established by the provider of the third party software.
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Terms and Conditions of the Software License

4.3When Yokogawa decides in its own judgement that it is necessary, Yokogawa may from time to time provide the Licensee with Release Upgrades specified by Yokogawa
(hereinafter called “Release Upgrades”).

4.4Notwithstanding the preceding Paragraph 4.3, in no event shall Yokogawa provide Updates where the Licensee or any third party conducted renovation or improvement
of the Licensed Software.

4.5Correction of nonconformity in the manner and for the period of time provided above shall be the Licensee’s sole and exclusive remedy for any failure of Yokogawa to
comply with its obligations and shall constitute fulfillment of all liabilities of Yokogawa and any third party licensing the Third Party Software to Yokogawa (including any
liability for direct, indirect, special, incidental or consequential damages) whether in warranty, contract, tort (including negligence but excluding willful conduct or gross
negligence by Yokogawa) or otherwise with respect to or arising out of the use of the Licensed Software.

4.6THE FOREGOING WARRANTIES ARE EXCLUSIVE AND IN LIEU OF ALL OTHER WARRANTIES OF QUALITY AND PERFORMANCE, WRITTEN, ORAL, OR
IMPLIED, AND ALL OTHER WARRANTIES INCLUDING ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE ARE
HEREBY DISCLAIMED BY YOKOGAWA AND ALL THIRD PARTIES LICENSING THIRD PARTY SOFTWARE TO YOKOGAWA.

Article 5 (Infringement)
5.11f and when any third party should demand injunction, initiate a law suit, or demand compensation for damages against the Licensee under patent right (including utility
model right, design patent, and trade mark), copyright, and any other rights relating to any of the Licensed Software, the Licensee shall promptly notify Yokogawa in writing
to that effect.
5.2In the case of the preceding Paragraph 5.1, the Licensee shall assign to Yokogawa all of the rights to defend the Licensee and to negotiate with the claiming party.
Furthermore, the Licensee shall provide Yokogawa with necessary information or any other assistance for Yokogawa’s defense and negotiation. If and when such a claim
should be attributable to Yokogawa, subject to the written notice to Yokogawa stated in the preceding Paragraph 5.1, Yokogawa shall defend the Licensee and negotiate
with the claiming party at Yokogawa'’s cost and expense and be responsible for the final settlement or judgment granted to the claiming party in the preceding Paragraph
5.1.
5.3When any assertion or allegation of the infringement of the third party’s rights defined in Paragraph 5.1 is made, or when at Yokogawa’s judgment there is possibility of
such assertion or allegation, Yokogawa will, at its own discretion, take any of the following countermeasures at Yokogawa'’s cost and expense.
a) To acquire the necessary right from a third party which has lawful ownership of the right so that the Licensee will be able to continue to use the Licensed Software;
b) To replace the Licensed Software with an alternative one which avoids the infringement; or
c) To remodel the Licensed Software so that the Licensed Software can avoid the infringement of such third party’s right.
5.41f and when Yokogawa fails to take either of the countermeasures as set forth in the preceding subparagraphs of Paragraph 5.3, Yokogawa shall indemnify the Licensee
only by paying back the price amount of the Licensed Software which Yokogawa has received from the Licensee.
THE FOREGOING PARAGRAPHS STATE THE ENTIRE LIABILITY OF YOKOGAWAAND ANY THIRD PARTY LICENSING THIRD PARTY SOFTWARE TO YOKOGAWA
WITH RESPECT TO INFRINGEMENT OF THE INTELLECTUAL PROPERTY RIGHTS INCLUDING BUT NOT LIMITED TO, PATENT AND COPYRIGHT.

Article 6 (Liabilities)

6.11f and when the Licensee should incur any damage relating to or arising out of the Licensed Software or service that Yokogawa has provided to the Licensee under the
conditions herein due to a reason attributable to Yokogawa, Yokogawa shall take actions in accordance with this Agreement. However, in no event shall Yokogawa be
liable or responsible for any special, incidental, consequential and/or indirect damage, whether in contract, warranty, tort, negligence, strict liability, or otherwise, including,
without limitation, loss of operational profit or revenue, loss of use of the Licensed Software, or any associated products or equipment, cost of capital, loss or cost of
interruption of the Licensee’s business, substitute equipment, facilities or services, downtime costs, delays, and loss of business information, or claims of customers of
Licensee or other third parties for such or other damages. Even if Yokogawa is liable or responsible for the damages attributable to Yokogawa and to the extent of this
Article 6, Yokogawa'’s liability for the Licensee’s damage shall not exceed the price amount of the Licensed Software or service fee which Yokogawa has received. The
Licensee agrees that Yokogawa shall be released or discharged from part or all of the liability under this Agreement if the Licensee modifies, remodels, combines with
other software or products, or causes any deviation from the basic specifications or functional specifications, without Yokogawa’s prior written consent.

6.2All causes of action against Yokogawa arising out of or relating to this Agreement or the performance or breach hereof shall expire unless Yokogawa is notified of the claim
within one (1) year of its occurrence.

6.3In no event, regardless of cause, shall Yokogawa assume responsibility for or be liable for penalties or penalty clauses in any contracts between the Licensee and its
customers.

Article 7 (Limit of Export)
Unless otherwise agreed by Yokogawa, the Licensee shall not directly or indirectly export or transfer the Licensed Software to any countries other than those where Yokogawa
permits export in advance.

Article 8 (Term)

This Agreement shall become effective on the date when the Licensee receives the Licensed Software and continues in effect unless or until terminated as provided herein,
or the Licensee ceases using the Licensed Software by itself or with Yokogawa’s thirty (30) days prior written notice to the Licensee. When aforesaid termination or cease is
occurred, the Licensee shall immediately destroy and/or eliminate the Licensed Software and related documents without retaining any copies or extracts thereof. However,
upon specifically instructed by Yokogawa, they shall be returned to Yokogawa or its designated third party.

Article 9 (Injunction for Use)
During the term of this Agreement, Yokogawa may, at its own discretion, demand injunction against the Licensee in case that Yokogawa deems that the Licensed Software is
used improperly or under severer environments other than those where Yokogawa has first approved, or any other condition which Yokogawa may not permit.

Article 10 (Termination)
Yokogawa, at its sole discretion, may terminate this Agreement without any notice or reminder to the Licensee if the Licensee violates or fails to perform this Agreement.
However, Articles 5, 6, and 11 shall survive even after the termination.

Article 11 (Jurisdiction)

Any dispute, controversies, or differences between the parties hereto as to interpretation or execution of this Agreement shall be resolved amicably through negotiation
between the parties upon the basis of mutual trust. Should the parties fail to agree within ninety (90) days after notice from one of the parties to the other, both parties hereby
irrevocably submit to the exclusive jurisdiction of the Tokyo District Court (main office) in Japan for settlement of the dispute to the fullest extent allowed by applicable law.

Article 12 (Governing Law)
This Agreement shall be governed by and construed in accordance with the laws of Japan. The Licensee expressly agrees to waive absolutely and irrevocably and to the
fullest extent permissible under applicable law any rights against the laws of Japan which may have pursuant to the Licensee’s local law.

Article 13 (Severability)
In the event that any provision hereof is declared or found to be illegal by any court or tribunal of competent jurisdiction, such provision shall be null and void with respect to
the jurisdiction of that court or tribunal and all the remaining provisions hereof shall remain in full force and effect.
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Overview of This Manual

Structure of This Manual
This user’s manual consists of the following chapters.

Chapter Title Description

1

Overview Gives an overview of the GateDX-P software.

Lists the PC requirements for running Gate-DXP and
gives information about system configuration.

Operating Procedure Gives procedures for entering environment and data
logging interval settings, and how to monitor the
operational status of the software.

Detailed Description of  Provides a detailed description of the functions of
Functions GateDX-P. Lists error messages, their causes, and their
corrective actions.

Index An alphabetical index of the manual's contents.

Scope of This Manual
This manual provides instructions on how perform basic operations with the software
when running under Windows XP, Windows 2000, and Windows Vista. For information
regarding the basic operations of Windows, see the Windows user’s manual.

Conventions Used in This Manual

Units

K Denotes 1024. Example: 10 KB
M Denotes 1024K. Example: 10 MB
G Denotes 1024M.  Example: 2 GB

Boldface Type
Hardware and software controls that the user manipulates such as dialog boxes,

buttons, and menu commands are often set in boldface type.

Subheadings
On pages in chapters 1 through 3 that describe operating procedures, the following
subheadings are used to distinguish the procedure from their explanations.

This subsection contains the operating procedure used to carry out
the function described in the current section. All procedures are

written with inexperienced users in mind; experienced users may
not need to carry out all the steps.

Note Calls attention to information that is important for proper operation
of the instrument.
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Chapter 1 Overview

1.1

Features

Overview of GateDX-P Functions

Gate-DXP is a software program that acquires data from the DX100P/DX200 and
transfers it to DAQLOGGER or Remote Monitor. Using GateDX-P allows you to monitor
data on DAQLOGGER or Remote Monitor that is measured on the DX100P or DX200P.
Yokogawa’s DAQLOGGER is a software program that allows users to open a connection
from their PC to various kinds of Yokogawa recorders (the mR, VR, DARWIN, DX, MV,
and CX) and perform data logging and monitoring.

Yokogawa’s Remote Monitor is application software that enables monitoring of data
logged by recorders or data logging software.

e -

* Runs as a Windows application.
* Up to 16 DX100P/DX200Ps can be linked.
« Measurement can be performed at intervals of up to 0.5 seconds .
* However, DAQLOGGER's shortest interval is 1 second. Also, the maximum speed of 0.5
seconds may not be attainable depending on the amount of data being read, the response
time of the device, and the communication speed.
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1.2 System Overview

System

This software can connect with and download data from DX100P/DX200Ps having the

following characteristics.

DX100P: Style 4 or later. The /C2 option is required for RS-232 communications.
The /C3 option is required for RS-422-A/485 communications.

DX200P: Style 4 or later. The /C2 option is required for RS-232 communications.
The /C3 option is required for RS-422-A/485 communications.

Required Operating Systems
Run DAQWORX under any of the following operating systems.

Windows 2000 Professional SP4

Windows XP Home Edition SP2, SP3

Windows XP Professional SP2, SP3 (excluding Windows XP Professional x64 Edition)
Windows Vista Home Premium, SP1 (excluding the 64-bit edition)

Windows Vista Business, SP1 (excluding the 64-bit edition)

The language displayed by the software under different language versions of the OS are

as follows.

OS Language Software Language
Japanese Japanese

Other English

Hardware Requirements
The following hardware is required to use GateDX-P.

PC:

Free disk space:

A PC that runs one of the OS above, and that meets the
following CPU and memory requirements.

When Using Windows 2000 or Windows XP

Pentium 4, 1.6 GHz or faster

512 MB or more of memory

When Using Windows Vista

Pentium 4, 3 GHz or faster

2GB or more of memory

200 MB or more

Communication device: An Ethernet (when connecting to DAQLOGGER or Remote

Monitor), RS-232, or GPIB port that is recognized by the
operating system.

CD-ROM drive: Used to install the software

Peripheral devices: A mouse supported by the operating system

GP-IB port: Required for GPIB communications between the software and
a WT series instrument

Monitor: When Using Windows 2000 or Windows XP
A monitor supported by the OS of 1024 x 768 dot or higher and
65,536 colors or more.
When Using Windows Vista
A video card recommended for use with Vista and monitor
supported by the OS of 1024 x 768 dot or higher and 65,536
colors or more.

Nofte

An RS-232 to RS-422-A/485 converter is required to perform communications between the
software and another DX100P/DX200P via RS-422-A/485 (Yokogawa ML2 RS232C/RS485

recommended).

1-2
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1.2 System Overview

System Configuration

—
GateDX-P

%  Geeswz@aes

B R ——

Remote Monitor

Ethernet

Up to 16 DX100P/DX200Ps

It is recommended that you run GateDX-P and DAQLOGGER on separate PCs.

Software Configuration

[ aenv o |
GateDX-P

Writes to file
Status information

- File read out -

Serial
communications
GateDX-P Configurator consists of two separate software functions. The role of each

DX100P/DX200P
function within the configurator is as follows:

¢ Environment Setting Functions
Acts as the user interface for GateDX-P.

These functions allow the user to enter various settings required by the executable
function for communications with the DX100P/DX200P, as well as those required for
data transfers to and from DAQLOGGER and Remote Monitor. The user can also
use the environment setting functions to start/stop the executable function, or view the
execution status.

¢ Executable Function
The software reads data from the DX100P/DX200P at fixed intervals. It also acts as a
monitor server, transferring data to DAQLOGGER and Remote Monitor.

DAQLOGGER

Ethernet

Ethernet

Remote Monitor

IM WX1-02E 1-3

e -



Chapter 2  Operation Procedure

2.1  Running and Exiting GateDX-P

Running the Software

Procedure

1. From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX >
GateDXP > GateDX-P.

The Gate-DX-P Configurator opens, displaying the user interface.
e

File Communication Execute Wiew Help
=] | N R

Recordsr Semng

_

Ready

Nofte

*  When you start GateDX-P it is restored to the same status that was active during the
previous session.

« If the program is closed while a process or service is running, the license will be considered
to be “in use.” If the message, “Invalid license number. Please reinstall.” appears when
restarting the program, it may indicate that the user is attempting to run a Gate program in
excess of the number of available licenses.

Starting GateDX-P in Acquisition Start Mode
1. From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX >
GateDXP > GateDX-P, then right-click GateDX-P and select Create Shortcut.

2. Right-click the shortcut icon and select Properties.

3. Choose the Shortcut tab, then add /START to the right of the path in the Target
box and click OK.

GateDX-P Properties ﬂll

General  Shortcut | Eompatibilityl

GateDi-P

Target type: Application

Target location: GateDxP

Target: IW’D R=hGateDxPyWGateD<PConfigE . exe /START

4. Choose the shortcut from the Windows Start menu. The connection status of the
previous session is restored, and acquisition begins.

Exiting the Software

Procedure

1. Choose File > Exit from the menu bar, or click the X button at the right end of the
title bar.

GateDX-P closes.

IM WX1-02E 2-1
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2.2

T

Serial Port Settings

Procedure

Entering Environment Settings

he following settings can be entered using the configurator.
DX100P/DX200P assignments, communications settings, and login settings
Acquisition interval settings for each DX100P/DX200P
Port number settings (for the monitor server) as needed
The settings can be saved

1. Click the Serial Setting tab or choose View > Serial Setting from the menu bar.
The Serial Setting tab is displayed.

4 GateDx-P Configurator =10 x|
File Communication Execute View Help
H &% |2

Setial Setting < B

Drag to select the
desired items

B

Type Biaud Rate Parity Bit

Click to display a list

Recorder Settings

Procedure

Copies the setting in the
first item of the selection
to all of the items in the
selectio

Turns the selected items ON and OFF

2. Enter settings for each item.

Port number: ON (blue)/OFF (gray)
Type: RS-232-C, RS-422-A/485
Baud rate: 9600,19200,38400
Parity: NONE, ODD, EVEN

Click the Recorder Setting tab or choose View > Recorder Setting from the
menu bar.

The Recorder Setting tab is displayed.

4 GateDX-F Configurator =0 x]
File Communication Execute View Help
(= s T S 74
Recorder Setting < >

Drag to select the items
for automatic model
determination

hodel Meaz Ch. ath Ch. Address

— Click to display a list

— Only the active COM ports
(specified in serial port
settings) are displayed

— Click to display the Input
Address dialog box

2-2
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2.2 Entering Environment Settings

Port Settings
2. Enter the port and address.
Port: Select the port to be used for the connection. Only the numbered COM
ports turned ON in the license setting tab are displayed.

For Ports Set to Ethernet
Click a cell in the address column to open the dialog box in the figure below.

Input Address - Recorder 01 x|

— Ether
IP Address or Host Mame

localhost

Uszer Mame I

Uszer ID I
Passward I

Cancel |

Enter the following settings.
IP address or host name: enter the IP address or host name of the DX100P/
DX200P to which you wish to connect.
User name: enter the user name specified on the DX100P/DX200P to which
you wish to connect.

User ID: enter the user ID specified on the DX100P/DX200P to which
you wish to connect.
Password: enter the password specified on the DX100P/DX200P to which

you wish to connect.

Nofte
When logging on to the DX100P/DX200P from GateDX-P, the default password for the

DX100P/DX200P cannot be used. If it is used, login will fail.

For Ports Set to COM
Click a cell in the address column to open the dialog box in the figure below.

Input Address - Recorder 02 x|

R5-422:4

om0z 03 04 05 06 07 08
03 0 C1 12 ©13 £ 14 15 16
CAF 18 19 © 20 & X © 22 230 M

025 26 27 28 29 30 O R 32

Cancel |

Select an RS-422-A address.

Address: only valid for COM ports using Ethernet or RS-422-A/485.

IM WX1-02E
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2.2 Entering Environment Settings

Automatic Model Determination

3. You can drag to select the items for automatic model determination.

4. Click Auto determination on the toolbar or choose Communication > Recorder

Model Determination from the menu bar.

ﬂ|%|%lﬁl> !|?|

Auto determination button

The following items are displayed.

Model:

Measurement channels:

Math channels:

The specific DX100P/DX200P models to be
connected.

The number of measurement channels on the
connected DX100P/DX200P.

The number of math channels on the connected
DX100P/DX200P.

4 GateDX-F Configurator =0 x]
File Communication Execute View Help
(= s T S 74
Recorder Setting < >

Ho. | Madel

o1

(-3 1ot Connected

Scan Interval and Retry Settings

Procedure

Meaz Ch.

ath Ch. Part Address
Ether ale: t

1. Click the Scan Interval Setting tab or choose View > Scan Interval Setting from

the menu bar.

The Scan Interval Setting tab is displayed.

4 GateDX-F Configurator =0 x]
File Communication Execute Wiew Help
H| & % @5 e
Scan Interval Setting < >
Retry
M. Scan Intervalimsec)
USE Interval(zec)

1000
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2.2 Entering Environment Settings

Setting the Scan Interval

2. Specify a scan interval from 0.5 to 3600 seconds.
Setting the Number of Retries

3. Turn the communication retry setting ON or OFF.
4. Enter the time interval between retries.
Setting range: 30-3600 seconds

Port Settings

Procedure

1. Click the Port Setting tab or choose View > Port setting from the menu bar.
The Port Setting tab is displayed.

§4 GateDX-P Configurator ] 5
File Communication Execute View Help

H &% @ E e

Port Setting

honitar a0282

2. You can change the port number used by the monitor server.

Saving Environment Settings
1 Click the Save button on the tool bar or choose File > Save from the menu bar.

ﬁ||@|m.@.!|?|

Save button
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2.3 Connecting from DAQLOGGER or Remote
Monitor

While the executable function is running, DAQLOGGER or Remote Monitor works via
Ethernet to log and monitor the data that the DX100P/DX200P is acquiring. Gate-DXP’
s executable function acts as the client of a DAQLOGGER or Remote Monitor that is
running as the monitor server.

In this case, system numbers are assigned as follows:
DX100P/DX200P assigned to Recorder1: 0
DX100P/DX200P assigned to Recorder2: 1

Connecting from DAQLOGGER

Procedure

See section 2.6 of the WX101 DAQLOGGER WX81 DAQLOGGER Client Package User’
s Manual (IM WX101-01E).

Connecting from Remote Monitor

Procedure

See section 8.1 of the WX101 DAQLOGGER WX81 DAQLOGGER Client Package User’
s Manual (IM WX101-01E), or section 9.2 of the WX102 DAQ32Plus WX82 DAQ32Plus
Client Package User’s Manual (IM WX102-01E).
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2.4 Process Run/Stop and Service Run/Stop

Running/Stopping from the Menu Bar

Procedure

Running as a Process or Service

1. Click the Service execution or Process execution button on the tool bar. Or,
choose Execute > Service or Execute > Process from the menu bar.

The executable function starts as a process or service. “Service” or “Process” is
displayed under Practice Status on the Practice Status tab.
|H|ﬂ|$> S !||?|

Stop button
Process execution button
Service execution button

Nofte

« Service execution can only be specified by users with Administrator privileges.
« Services cannot be executed when using Windows Vista.

Stopping the Process or Service
1. Click the Stop button on the tool bar or choose Execute > Stop from the menu bar.
The Practice Status item shown on the Practice/Status tab displays “Stop.”

Running/Stopping the Executable Function from the Execution/Status Tab

Procedure

1. Click the Execution/Status tab or choose View > Execution/Status from the menu bar.
The Execution/Status tab is displayed.

4 GateDX-P Configurator o ] |
File Communication Execute View Help

H| | s @ !|?|

Scan Interval Setting T Port Setting T Execution/Status I

—Practice —Status
I Practice Status : Process
L - - Select the practice type
& Process Cliert Connection Status
B ks-hiro
] Seryice Bke-hiro
Start
Stop

Running as a Process or Service

2. Select to execute the function as a process or service.
3. Click Practice.
The executable function starts, and “Service” or “Process” is displayed under
Practice Status.
Stopping the Process or Service

2. Click the Stop button.
“Stop” is displayed for the practice status.
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2.5 Viewing the Status of the Executable Function

Procedure

Displaying the Connection Status

1. Click the Execution/Status tab, or choose View > Execution/Status from the
menu bar.

The Execution/Status tab is displayed, allowing you to see the method under
which the executable function may be running (as a process or as a service),
whether or not it is running, and with which PCs communications are open.

88 Giate DIX-F Gonfieurator o [

Eile  Gommunication Execution Miew Help

(&% mu]e]

Sean Interval Setting T Port Setting T Execution/Status -ﬂn

- Execution -~ Status

Execution Status @ Process
Type —

Client Connection Status:

Displays the names
of connected clients

Double-click to
display the Error
Indicator dialog box

Ready

Select the Displays the communications status with the client
practice type Gray: Stopped
Red: Error

Green: Normal
Viewing Error Detail

2. Double-click the box displaying the client communication status on the Execution/
Status tab (shown above).

The Error Indicator dialog box opens.

Error Indicator

ox

See section 3.3 for error messages.

Nofte
» If a warning message is displayed (code Wxxxx), the lamp that displays the connection
status by color does not blink red.
*  When an error occurs and the lamp blinks red, the Error Indicator dialog box appears. If you
close the dialog box, the lamp turns green.
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2.6 Viewing Version Information

Procedure

1. Click the About button on the tool bar or choose Help > About from the menu bar. n

H| | s @ !|‘F|
About button

The Version dialog box opens.

alnpasold uonelado

GateD¥-P Configuratar
[0F bl

Copyright (C) 2003 YOROGAWA Electric Corparation

This Product is licensed to:

Company name

User name

[ License number |
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Chapter 3

Detailed Description of Functions

3.1

Overview

Gate-DXP performs Ethernet communications with the DX100P/DX200P and acquires
data at regular intervals. Through the monitor server function, the acquired data is
transferred to DAQLOGGER or Remote Monitor via Ethernet.

The following is a list of the features of each software function.

Environment Setting Functions

Environment setting functions are used to enter all environment settings required to run
the executable function.

Serial Port Settings (as Needed)
Port

Type (RS-422A/485 or RS-232-C)

Baud rate

Parity

Recorder Settings

Port

Address

User name

User ID

Password

Automatic model determination

Scan Interval Settings

Scan interval setting for each recorder (0.5 to 3600 sec.)
Communication retry ON and OFF

Retry interval

Port Settings

Port number for monitor server

Port number for getting status

Executable Function Start/Stop

Runs as a service

Runs as a process

Executable Function Status Display
Practice status display (stopped, running as a service, running as a process)
Display of the connection status from the client

Executable Function
Features of the executable function are as follows:

Running as a process and as a service is possible.

Instantaneous data values are acquired from up to 16 DX100p/DX200Ps at regular
intervals.

Runs as a monitor server via Ethernet if DAQLOGGER or Remote Monitor is the
client.

IM WX1-02E
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3.2 Detailed Description of Functions

Serial Port Settings

Recorder Settings

Scan Interval

GateDX-P can use the COM1-COM9 serial ports.
The user must enter the following port settings.

* Use/Do not use (ON/OFF)

* Type (RS-422-A/485 or RS-232-C)

+ Baud rate: 4800, 9600, 19200, 38400 bps

+ Parity bit: NONE, ODD, EVEN

GateDX-P allows simultaneous connection with any combination of 16 DX100p/
DX200Ps.

The user must enter the following recorder settings.

» Port (COMx or Ethernet)

» Address number (if a COM port using RS-422-A/485 is selected)

» |P address or host name (if Ethernet is selected for the port)

» User name (if Ethernet is selected for the port)

» User ID (if Ethernet is selected for the port)

» Password (if Ethernet is selected for the port)

» Automatic Model Determination

If communication settings are entered correctly, the models, number of measurement
channels, and number of computation channels are identified by the software.

A scan interval from 0.5 to 3600 seconds is selected for each of the 16 DX100P/
DX200Ps.

Nofte
When connecting to DAQLOGGER and acquiring data from the DX100P/DX200P, if GateDX-P’

s scan interval is longer than that of DAQLOGGER, DAQLOGGER logs the same data
repeatedly until the next Gate-DXP scan interval. Therefore, it is recommended that GateDX-P’
s scan interval be set to a value smaller than DAQLOGGER'’s scan interval.

Communication Retry

Using the Configurator, you can turn communication retry ON and OFF, and set the retry
interval.
¢ When Communication Retry Is OFF
After detecting that communications were cut, no attempts are made to reconnect.
¢ When Communication Retry Is ON
After detecting that communications were cut, the software attempts to reconnect
after the retry interval has elapsed. Even if the reconnection resulted in an error,
the software waits again for the retry interval to elapse, then attempts another
reconnection. This process repeats until a valid connection is opened.
A communication retry interval of 30 to 3600 seconds can be entered.

Nofte

GateDX-P considers communications to have been cut in the following circumstances.

» If the executable function requests data from a DX100P/DX200P but no response is
received within 10 seconds.

» fthe software detects that the TCP/IP connection was dropped when the executable
function is connected to the DX100P/DX200P via Ethernet.
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3.2 Detailed Description of Functions

Port Settings

GateDX-P uses the following ports.

¢ Monitor Server Port
The TCP/IP port number used for communication with DAQLOGGER or Remote
Monitor.

Running/Stopping the Executable Function

The user interface allows you to start and stop the executable function.

The executable function runs under one of the following two methods or “types.”

* Process Run/Stop
The executable function is run/stopped as a process.

» Service Run/Stop
The executable function is registered as an automatically executing service, then
run. After an executable function running as a service is stopped, its registration as
a service is deleted. As indicated by the service execution status, the executable
function continues processing even when the user has logged off of Windows.
Also, the software is automatically run as a service when the computer is turned
ON. Service execution can only be specified by users with Administrator privileges.
Services cannot be executed when using Windows Vista.

Monitor Server Function of the Executable Function

When the executable function is running, you can connect from DAQLOGGER or
Remote Monitor via Ethernet using the remote monitor protocol, and acquire data. In this
case, system numbers are assigned as follows:

DX100P/DX200P assigned to Recorder1: system number 0

DX100P/DX200P assigned to Recorder2: system number 1

Executable Function Status Display

The user interface allows you to display status items for the executable function.

The information that can be displayed is as follows:

» Practice status (stopped, running as a service, running as a process)

» Connection status from the client
Displays a list of PCs running DAQLOGGERS and Remote Monitors with which the
executable software has opened a connection.

Group and Channel Assignments

When connected to GateDX-P using Remote Monitor, the initial status of group and
channel assignments are as follows:

Group Name Waveform Number Channel Assignment
Group 1 Measure Ch W01 CHO1
W30 CH30
Group 2 Math Ch W01 CH31
W30 CH60

Nofte

When connecting DAQLOGGER to Gate-DXP, group and waveform assignments are ignored.

IM WX1-02E 3-3
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2.2 Entering Environment Settings

Channel Names, Tag IDs, and Tag Names

When connected to GateDX-P using Remote Monitor, the channel names, tag IDs, and
tag name assignments are as follows:

DX100P/DX200P Channel Channel Name Tag ID Tag Name

CHO1 CHO1 CHO1 DX100P/DX200P tagname

CH60 CH60 CH60 DX100P/DX200P tag name
Nofte

When connecting DAQLOGGER to Gate-DXP, channel names and tag IDs are ignored. You
can download tag names using tag setting software.

Channel Colors

The default channel colors on GateDX-P are those specified on the connected DX100P/
DX200P.
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3.3

Error Messages and Corrective Actions

Error
No. Message Corrective Actions
E211 Cannot write to file. Check if the disk capacity is sufficient or if the file systems is
normal.
E212 Cannot read file. Check if the file exists and is supported by the software or if the
file system is normal.
E213 Cannot open file. Check if the file exists and is supported by the software or if the
file system is normal
E401 Communication error. Check if the recorder connected for communication is powered on
and if the cable is properly connected. Also check the following
items according the the communication type.
* For Ethernet
Check if address settings are correct; the TCP/IP protocol is
installed in Windows; the Ethernet card is properly installed.
» For RS-232 and RS-422-A
Check if the baud rate settings match; the port (COM1 to COM9)
settings match, the address settings are correct (RS-422-A); the
serial port of the PC is active and the appropriate cable is being
used.
E402 Communication timeout. -
E403 Cannot open a communication port. Same as E401.
E501 Invalid license number.
Please reinstall the software.
E1001 Login error. Check the user name, user ID, and password on the DX-P.
E1002 Invalid password. -
E1003 Password is not valid. -
E1004 Password expired. -
Please set up a password again on the DX-P.
E1010 Execution of aprocess failed. Check whether an executable function exists, or whether its
files are damaged. If this error appears frequently, reinstall the
software.
E1011 Execuition of a service failed. Check whether an executable function exists, or whether its
files are damaged. If this error appears frequently, reinstall the
software.
E1012 Login prohibited because another user is -
logged in.
Message
No. Message
M1201 Model determination was successful.
M1210 Setting changes saved before execution.

Executable Function Messages

No. Message Corrective Actions

WI[631] Data Lack Reduce the number of acquired data points or connected
instruments, or lengthen the scan interval.

E[673] Cannot open communication Same as E401.

E[674] Communication error Same as E401.

E[675] Communication time out Same as E401.

E[700] Cannot login Same as E1013.

E[701] Cannot Get DXP inoformation Check whether the communication status and connected
instruments matches those specified in the software. If they do
not, perform model determination again.

1[606] Recovery Communication Connection recovered.
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